Вопрос по информатике:
Программа на с++
Подсчитайте количество натуральных делителей числа x (включая 1 и само число; x <= 30000).
Входные данные
Вводится натуральное число x.
Выходные данные
Выведите единственное число - количество делителей числа x.
Примеры
входные данные
7
выходные данные
2
входные данные
21
выходные данные
4
- 04.11.2016 06:36
- Информатика
- remove_red_eye 15722
- thumb_up 17
Ответы и объяснения 1
using namespace std;
int main(){
int x{},k{};
cin >> x;
for(int i = 1; i <=x; i++){
if(a%i==0){
k++
}
}
cout << k;
return 0;
}
- 05.11.2016 01:34
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.