Вопрос по информатике:
Дано несколько чисел. Вычислите их сумму. Сначала вводите количество чисел N, затем вводится ровно N целых чисел. Какое наименьшее число переменных нужно для решения этой задачи?
Входные данные
В первой строке вводится натуральное число N - количество чисел. В следующих N строках вводится по одному целому числу.
Выходные данные
Выведите ответ на задачу.
Примеры
входные данные
2
235
56
выходные данные
291
решение для паскаля
- 16.11.2017 00:57
- Информатика
- remove_red_eye 10614
- thumb_up 5
Ответы и объяснения 1
begin
readln(n);
s:=0;
for i:=1 to n do
begin
readln(a);
s:=s+a;
end;
writeln(s);
end.
Пример:
3
12
54
91
157
- 16.11.2017 01:30
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.