Вопрос по информатике:
Сложные условия ВЕТВЛЕНИЯ ПАСКАЛЬ!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке.
Пример:
Введите три числа:
5 5 5
Все числа одинаковые.
Пример:
Введите три числа:
5 7 5
Два числа одинаковые.
Пример:
Введите три числа:
5 7 8
Нет одинаковых чисел.
- 25.05.2018 02:11
- Информатика
- remove_red_eye 18132
- thumb_up 8
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
case ReadSeqInteger('Введите три целых числа:',3).Distinct.Count of
3:Writeln('Нет одинаковых чисел');
2:Writeln('Два числа одинаковые');
else Writeln('Все числа одинаковые')
end
end.
Примеры
Введите три целых числа: 5 5 5
Все числа одинаковые
Введите три целых числа: 5 7 5
Два числа одинаковые
Введите три целых числа: 5 7 8
Нет одинаковых чисел
- 26.05.2018 19:53
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.