Вопрос по информатике:
Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел.
Входные данные
Входная строка содержит 5 целых чисел, разделённых пробелами.
Выходные данные
В первой строке нужно вывести минимальное из введённых чисел, во второй строке – максимальное.
Примеры
входные данные
1 2 3 4 5
выходные данные
1
5
- 02.03.2015 17:32
- Информатика
- remove_red_eye 10116
- thumb_up 40
Ответы и объяснения 1
int main() { setlocale(LC_ALL, "");
int arr[5];
for (int i = 0; i < 5; ++i) { std::cout <> arr[i]; }
int min = arr[0], max = min;
for (int i = 0; i < 5; ++i) { if (arr[i] max) max = arr[i]; }
std::cout << min << "\n" << max; _getch(); return 0;}
- 03.03.2015 05:06
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.