Вопрос по информатике:
Программа на C++
Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.
Входные данные
Входная строка содержит два целых числа.
Выходные данные
Программа должна вывести произведение введённых чисел.
Примеры
входные данные
6 12
выходные данные
72
входные данные
-7 15
выходные данные
-105
- 26.10.2017 15:56
- Информатика
- remove_red_eye 9141
- thumb_up 25
Ответы и объяснения 2
using namespace std;
int multiply(int x, int y)
{
if(y == 0)
return 0;
if(y > 0)
return (x + multiply(x, y - 1));
if(y < 0)
return -multiply(x, -y);
}
int main()
{
int a, b;
cin >> a >> b;
cout << multiply(a, b) << endl;
return 0;
}
- 27.10.2017 18:18
- thumb_up 43
#include
int
main(void)
{
int a = 0;
int b = 0;
scanf("%d %d", &a, &b);
long long mul = 0;
for (int i = 0; i < abs(a); i++) {
mul += b;
}
if (a < 0) {
mul = -mul;
}
printf("%lld\n", mul);
return 0;
}
- 28.10.2017 07:16
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.