Вопрос по информатике:
Даны произвольные числа a,b,c. Выяснить существует ли треугольник с такими длинами сторон. Если треугольник существует, то определить является ли он равносторонним ил каким-либо иным. Написать программу в с++
очень нужно
- 12.07.2015 14:50
- Информатика
- remove_red_eye 4709
- thumb_up 12
Ответы и объяснения 1
псевдокод
bool Triangle(int &a, int &b, int &c)
{
return ((a + b > c) && (b + c > a) && (c + a > b));
}
...
int Type(int a, int b, int c)
{
if(a == b == c) {
return 0;
} else {
if(a==b || c == b || a == c) {
return 1;
}
return 2;
}
}
int main()
{
...
if(Triangle(a, b, c)) {
cout<<(Type(a, b, c) == 0) ? "равносторонний" : (Type(a, b, c) == 1) ? "равнобедренный" : "разносторонний";
} else {
cout<<"Это не треугольник";
}
...
return 0;
}
- 13.07.2015 08:06
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.