Вопрос по информатике:
Заполните массив с клавиатуры целыми числами. Определите, есть ли в данном массиве положительные элементы, кратные числу A заданному с клавиатуры?
Если есть, то вывести слово «YES», иначе — «NO».
Входные данные:
в первой строке целое число n (0 < n ≤ 100) — кол-во элементов в массиве и число целое А (по модулю не превосходит 32000). Во второй строке целые числа Х1, Х2,..,Хn разделенные пробелом (числа по модулю не превосходят 32000) — значения элементов массива.
Выходные данные:
слово «YES» или «NO» в соответствии с условием задачи.
на ПАСКАЛЕ.......
Пожалуйста...
- 18.01.2017 06:19
- Информатика
- remove_red_eye 17620
- thumb_up 16
Ответы и объяснения 1
yes,no:string;
a,n,i:longint;
c:integer;
b:array [1..100] of longint;
begin
writeln('введите кол-во элементов в массиве');
read(n);
writeln('введите число A');
read(a);
For i:=1 to n do readln(b[i]);
for i:=1 to n do
if b[i] mod a = 0 then
begin
yes:='YES';
end
else
no:='NO';
begin
end;
begin
if yes = 'YES' then
begin
writeln(yes);
end
else
writeln(no);
end;
end.
Пробуй так
- 19.01.2017 05:15
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.