Вопрос по информатике:
№17а. Дано трехзначное число. В нем зачеркнули первую слева цифру и приписали ее справа. Вывести полученное число.
№37. Даны три числа. Составить программу нахождения суммы двух наибольших из этих трех чисел.
Помогите пожалуйста паскаль!!!!!!!!!!!!!!!
- 07.02.2016 04:37
- Информатика
- remove_red_eye 8304
- thumb_up 16
Ответы и объяснения 1
begin
write('Введите трехзначное число: ');
readln(a);
writeln('Результат: ',(a mod 100)*10+(a div 100));
end.
var a,b,c:integer;
begin
writeln('Введите a,b,c');
write('a=');
readln(a);
write('b=');
readln(b);
write('c=');
readln(c);
if a+b>b+c then
begin
if a+b>a+c then
write('a+b=',a+b)
else
write('c+a=',c+a);
end
else if b+c>=a+b then
begin
if b+c>c+a then
write('b+c=',b+c)
else
write('c+a=',c+a);
end
else
write('c+b=',c+b);
end.
- 08.02.2016 12:56
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.