Вопрос по информатике:
Напишите программу которая в последовательности натуральных чисел определяет произведение двухзначных чисел кратных 4 и оканчивающихся на 4 .Программа получает на вход количество чисел в последовательности а затем сами числа
- 23.07.2017 20:45
- Информатика
- remove_red_eye 13736
- thumb_up 35
Ответы и объяснения 1
var
count, comp, num : integer;
begin read(count); comp:=1; while count>0 do begin count:=count-1; read(num); if (num div 100 = 0) and (num mod 4 = 0) and (num mod 10 = 4) then comp:=comp*num; end; write('Произведение чисел - ',comp); end.
- 24.07.2017 10:32
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.