Вопрос по информатике:
СРОЧНО!!!!!! ОЧЕНЬ НАДО!!!!!!!!!!
c++
Напишите функцю void reduce_fraction(int *n, int *m), которая сократит дробь , то есть изменит числа, которые лежат по указателям n и m таким образом, что значение дроби останется прежним, но она будет несократимой.
После написания функции требуется решить задачу, в которой вводятся натуральные числа a и b, после чего дробь сокращается, и выводится уже в сокращенном виде.
Формат входных данных
Вводятся два натуральных числа a и b, не превосходящие 100.
Формат выходных данных
Требуется вывести сокращенную дробь.
Примеры
входные данные
выходные данные
12
16
3 4
- 03.09.2017 09:14
- Информатика
- remove_red_eye 15188
- thumb_up 27
Ответы и объяснения 1
using namespace std;
int reduce_fraction(int n, int m)
{
if (m == 0) {
return n;
}
return reduce_fraction(m, n % m);
}
int main()
{
int num, dem;
cout << "Nominator: ";
cin >> num;
cout << "Denominator: ";
cin >> dem;
int nod = reduce_fraction(num, dem);
cout << num << '/' << dem < " << (num / nod) << '/' << (dem / nod) <<
endl;
return 0;
}
- 04.09.2017 09:10
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.