Вопрос по информатике:
Написать программу для вычисления корней квадратного уравнения С++
- 14.08.2018 16:34
- Информатика
- remove_red_eye 15536
- thumb_up 6
Ответы и объяснения 1
#include
using namespace std;
int main()
{
double a;
double b;
double c;
double x;
cout << "Введите значение a: ";
cin >> a;
cout << "Введите значение b: ";
cin >> b;
cout << "Введите значение c: ";
cin >> c;
if((b*b - 4*a*c) >= 0) //Если дискриминант больше или равен 0
{
x = ( -1*b + sqrt(b*b - 4*a*c) ) / (2 * a);
cout << "Первый корень равен " << x << endl;
x = ( -1*b - sqrt(b*b - 4*a*c) ) / (2 * a);
cout << "Второй корень равен " << x << endl;
}
else
{
cout << "Дискриминант меньше 0, нет вещественных корней." << endl;
}
return 0;
}
- 15.08.2018 19:16
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.