Вопрос по информатике:
Помогите пожалуйста, нужно составить программу обработки данной строки, позволяющую выписать все знаки сравнения и все скобки, сохранив их последовательность
- 11.10.2015 12:42
- Информатика
- remove_red_eye 14308
- thumb_up 29
Ответы и объяснения 2
var s:string;
i:integer;
begin
readln(s);
for i:=1 to s.Length do begin
if ((s[i]=')') or (s[i]='(') or (s[i]='>') or (s[i]='<') or (s[i]='=')) then write(s[i]);
end;
end.
Я надеюсь, =() - это все знаки, которые вы перечислили?
- 12.10.2015 19:06
- thumb_up 29
// Внимание! Если программа не работает, обновите версию!
begin
ReadlnString('Введите строку:').MatchValues('[()=]').Println('')
end.
Пример
Введите строку: Пусть F(x)=3a/x+(x-1)>5x/(2-x), тогда ...
()=()>()
- 13.10.2015 15:12
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.