Вопрос по информатике:
Помогите пожалуйста написать программу, язык Pascal.
Ввести целое положительное число трехзначное число N. Разбить это число на разряды (найти число сотен, десятков и единиц). Найти сумму разрядов числа N
- 03.05.2015 09:16
- Информатика
- remove_red_eye 18032
- thumb_up 14
Ответы и объяснения 1
var n,a,b,c,s: integer;
begin
write('введите положительное трехзначное число - '); readln(n);
a:=n mod 10; {последняя цифра}
b:=(n div 10) mod 10; {средняя цифра}
c:=n div 100; {первая цифра}
writeln('сотен - ', с, ', десятков -',b,', единиц - ',a);
s:=a +b+c:
writeln('сумма цифр числа - ',s)
end.
- 04.05.2015 03:39
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.