Вопрос по информатике:
Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.
- 20.12.2015 21:51
- Информатика
- remove_red_eye 7687
- thumb_up 44
Ответы и объяснения 1
1)var t: array [1..12] of real;
i: integer;
begin
for i:=1 to 12 do readln(t[i]);
writeln('Средняя температура зимних месяцев: ',((t[12]+t[1]+t[2])/3):0:3);
writeln('Средняя температура весенних месяцев: ',((t[3]+t[4]+t[5])/3):0:3);
writeln('Средняя температура летних месяцев: ',((t[6]+t[7]+t[8])/3):0:3);
writeln('Средняя температура осенних месяцев: ',((t[9]+t[10]+t[11])/3):0:3);
end.
2)var t: array[1..10] of integer;
c: array[1..10] of real;
i: integer;
s,s1: real;
begin
s:=0;
for i:=1 to 10 do begin writeln('Введите количество товара'); readln(t[i]) ; end;
for i:=1 to 10 do begin writeln('Введите цену товара');readln(c[i]);end;
for i:=1 to 10 do begin s1:=t[i]*c[i];
s:=s+s1;
end;
writeln('Общая стоимость всех покупок: ',s:0:3);
end.
- 21.12.2015 18:27
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.