Вопрос по информатике:
Требовалось написать программу при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10^9 и выводится максимальная цифра этого числа.
var N: longint;
digit, maxdigit: integer;
begin
readln(N);
maxdigit := 10;
while N > 10 do
begin
digit := N mod 10;
if digit > maxdigit then
maxdigit := digit;
N := N div 10;
end;
writeln(digit);
end.
Последовательно выполните следующее.
1. Напишите что выведет это программа при вводе числа 321.
2. Найдите все ошибки в этой программе (их может быть одна или несколько). Для каждой ошибки:
1) выпишите строку, в которой сделана ошибка;
2) укажите, как исправить ошибку, - приведите правильный вариант строки.
- 14.01.2018 08:24
- Информатика
- remove_red_eye 9883
- thumb_up 50
Ответы и объяснения 1
2)
var
N: longint;
digit, maxdigit: integer;
begin
readln(N);
maxdigit := 10; // нужно присваивать 0
while N > 10 do // нужно написать N > 0
begin
digit := N mod 10;
if digit > maxdigit then
maxdigit := digit;
N := N div 10;
end;
writeln(digit); // нужно вывести maxdigit
end.
Верный код
var
N: longint;
digit, maxdigit: integer;
begin
readln(N);
maxdigit := 0;
while N > 0 do
begin
digit := N mod 10;
if digit > maxdigit then
maxdigit := digit;
N := N div 10;
end;
writeln(maxdigit);
end.
- 15.01.2018 05:39
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.