Вопрос по информатике:
Помогите! Язык Си
Написать программу,которая находит количество простых членов последовательности.
- 20.08.2017 05:12
- Информатика
- remove_red_eye 13827
- thumb_up 42
Ответы и объяснения 1
char IsSimple( int num )
{
int i;
if (num -2)
return 0;
for (i = 2; i < num / 2 + 1; i++)
{
if (num % i == 0)
return 0;
}
return 1;
}
void main( void )
{
int i;
int
*mainArray,
numOfEl,
numOfPrimeNum = 0;
printf("Input a number of the elements in the sequence: ");
scanf("%i", &numOfEl);
mainArray = (int *)malloc(sizeof(int) * numOfEl);
for (i = 0; i < numOfEl; i++)
{
scanf("%i", &mainArray[i]);
if (IsSimple(mainArray[i]))
numOfPrimeNum++;
}
printf("Number of the prime numbers is %i\n", numOfPrimeNum);
system("pause");
} /* End of the 'main' function */
- 21.08.2017 16:20
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.