Вопрос по информатике:
Составить алгоритм и написать программу вычисления площади геометрической фигуры с использованием условного оператора if по одной из формул: S=п*r ; S=a*b
- 11.09.2015 22:31
- Информатика
- remove_red_eye 4520
- thumb_up 22
Ответы и объяснения 1
var
s,r,a,b:real;
k:byte;
begin
repeat
write ('1 - S kruga; 2 - S pryamougolnika: ');readln(k);
until (k=1) or (k=2);
if k=1 then begin
write ('Radius: ');readln(r);
s:=pi*r;
writeln ('S = ',s:0:5);
end else begin
write ('A = ');readln(a);
write('B = ');readln(b);
s:=a*b;
writeln ('S = ',s:0:4);
end;
readln;
end.
- 13.09.2015 10:53
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.