Вопрос по информатике:
Написать программу, которая:
1. Дано вещественное число x, посчитать функцию, возвращающую y=f(x), если
2. F(x) = 2*x, при x < 0;
3. F(x) = 0, при x = 0;
4. F(x) = x*x + 10, при x> 0;
Написать программу, которая:
1. Просит ввести год рождения человека;
2. Проверяет введенное значение (несколько параметров);
3. Вычисляет возраст человека;
4. Выводит на экран возраст и какую-либо характеристику (несколько параметров в зависимости от возраста в трех диапазонах).
- 14.10.2015 11:59
- Информатика
- remove_red_eye 9324
- thumb_up 44
Ответы и объяснения 1
#include
float mathFunc(float x) {
if (x < 0)
return 2 * x;
else if (x > 0)
return x * x + 10;
return 0;
}
int main() {
setlocale(LC_ALL, "");
std::cout << mathFunc(-1) << " " << mathFunc(0) << " " << mathFunc(1);//проверка
_getch();
return 0;
}
//1
#include
#include
int main() {
setlocale(LC_ALL, "");
int year;
while (true) {
system("cls");
std::cout << "Введите год своего рождения:";
std::cin >> year;//год может быть отрицательным => до н.э.
year = 2017 - year;
printf("Вам %d лет,", year);
if (year < 45)
printf("вы молоды");
else if (year < 60)
printf("вы среднего возраста");
else if (year < 75)
printf("вы пожилого возраста");
else if (year > 90)
printf("вы старческого возраста");
_getch();
return 0;
}
//2
- 15.10.2015 18:45
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.