Вопрос по информатике:
13. Дано число n. Составьте программу для вычисления суммы: s = 1 + 2 + 3 + ... + n.
14. Составьте программу в Gpaph ABC. Нарисовать ряд закрашенных в зеленый цвет кругов радиуса 20 пикселей вдоль верхнего края экрана монитора
16. Составьте программу для вычисления числа n: n = 1∙2∙3∙…∙х. Число Х вводится с клавиатуры.
- 15.09.2016 13:57
- Информатика
- remove_red_eye 13178
- thumb_up 32
Ответы и объяснения 1
var
sum:BigInteger;
i,n:integer;
begin
write ('n = ');
readln(n);
sum:=0;
i:=1;
while i<= n do begin
sum:=sum+i;
i:=i+1;
end;
writeln('Sum = ',sum);
end.
================================
program krugi;
uses graphabc;
var
x,y,r:integer;
begin
setBrushColor(clGreen);
x:=22; y:=22; r:=20;
while x<660 do begin
circle(x,y,r);
x:=x+40;
end;
end.
==============================
program factorial;
var
pr:BigInteger;
i,n:integer;
begin
write ('n = ');
readln(n);
pr:=1;
i:=1;
while i<= n do begin
pr:=pr*i;
i:=i+1;
end;
writeln('Факториал числа n! = ',pr);
end.
- 16.09.2016 03:11
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.