Вопрос по информатике:
Напишите программу, которая заполняет массив из 20 элементов натуральными числами и считает разность произведений четных и нечетных элементов массива(paskal)
- 26.05.2015 13:51
- Информатика
- remove_red_eye 7917
- thumb_up 10
Ответы и объяснения 1
b: array[1..20] of BigInteger;
pr, pr1, raz: BigInteger;
begin
pr := 1;
pr1 := 1;
for var i := 1 to 20 do
begin
b[i] := random(100) + 10;
write(b[i]+' ');
if b[i] mod 2 = 0 then
pr := pr * b[i];
if b[i] mod 2 0 then
pr1 := pr1 * b[i];
raz := pr - pr1;
end;
writeln();
writeln('Разница равна ', raz);
end.
- 27.05.2015 20:03
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.