Вопрос по информатике:
Напишите программу по последовательному вводу пяти различных чисел чисел. Причём программа не должна разрешать ввод одинаковых чисел.
- 03.08.2015 21:14
- Информатика
- remove_red_eye 5017
- thumb_up 17
Ответы и объяснения 2
N = 5;
Var
P:array[1..N] of integer;
C,i,j,B:integer;
Begin
WriteLn('Введите пять целых чисел');
For i:=1 to N do
Begin
Repeat
B:=0;
Read(C);
For j:= 1 to i-1 do
if P[j] = C then B:=j;
if B > 0 then WriteLn('Число ',P[B],' уже было'#13'Попробуйте ещё раз')
else P[i]:=C;
Until B = 0;
End;
WriteLn('Полученная последовательность');
For i:= 1 to N do Write(P[i],' ')
End.
- 05.08.2015 16:03
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.
