Вопрос по информатике:
С клавиатуры вводится n чисел. Написать программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введённых чисел. Значение n также вводится с клавиатуры. Язык С++
- 23.05.2018 10:05
- Информатика
- remove_red_eye 7451
- thumb_up 41
Ответы и объяснения 1
using namespace std;
int main()
{
int n, A, P = 0, O = 0, N = 0;
cout <> n;
for (int i = 0; i < n; i++)
{
cin >> A;
if (A > 0) P++;
else if (A < 0) O++;
else N++;
}
cout << "( < 0): " << O;
cout << "\n( = 0): " << N;
cout < 0): " << P;
return 0;
}
- 24.05.2018 02:39
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.