Вопрос по информатике:
Помогите написать программу на паскале абс
Дано трехзначное число. Найдите его палиндром и произведение палиндрома и данного числа. Числовой палиндром — это натуральное число, которое читается слева направо и справа налево одинаково. Иначе говоря, отличается симметрией записи (расположения цифр), причём число знаков может быть как чётным, так и нечётным. Например, 165 его палиндром 561.
- 07.07.2016 15:20
- Информатика
- remove_red_eye 7316
- thumb_up 51
Ответы и объяснения 1
Program palidron;
var
a, b, c, x, d: integer;
begin
writeln('Число:');
readln(a);
b:= a mod 10;
c:= (( a div 10) mod 10);
x:= (( a div 10) div 10);
d:= 100*b+10*c+x;
writeln('Палиндром: ',b,c,x);
writeln('Произведение числа и палиндрома: ',d*a);
end.
- 08.07.2016 09:22
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.