Вопрос по информатике:
.Помогите пожалуйста очень срочно.Написать программу в любой программе(лучше всего на сишарп), которая преобразует целое положительное десятичное число (число разрядов не более 6) в его эквивалент в 2 систему счисления. Программа должна вводить число в 10 систему счисления и печатать результат в 2 системе счисления. Например:
Введите целое число в 10c/c: 12
Двоичный эквивалент равен 1100
Незначащие нули должны подавляться. Должен быть контроль вводимых цифр. Разрешены цифры 0 - 9.
- 08.11.2017 17:23
- Информатика
- remove_red_eye 3040
- thumb_up 46
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
function Dec2Bin(x:string):string;
begin
var s:=x.MatchValue('\d+');
if s.Length=0 then begin
Writeln('Не найдено НИ ОДНОЙ цифры!');
Result:=''
end
else begin
var t:=s.ToInteger;
var r:string:='';
while t>=2 do (r,t):=(t mod 2+r,t shr 1);
Result:=t+r
end
end;
begin
Writeln(Dec2Bin(ReadlnString('n=')))
end.
- 09.11.2017 03:43
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.