Вопрос по информатике:
1)дано трехзначное
число.Составьте программу которая определяет а)является ли сумма его цифр нечетным числом
2)Составьте программу в которой осуществляется вот целых чисел до тех пор пока не будет введен 0 и подсчет а)количество чисел оканчивающихся на 6 и кратных 4 б)Сумма чисел оканчивающихся на 6 и кратных 4
на языке Паскаль
- 05.09.2018 19:55
- Информатика
- remove_red_eye 2762
- thumb_up 16
Ответы и объяснения 1
Program hhh54;
var x:longint;
begin
read (x);
if ((x div 100) + ((x div 10) mod 10) + (x mod 10)) mod 2 0 then write ('ЯВЛЯЕТСЯ')
else write ('НЕ ЯВЛЯЕТСЯ');
end.
2)
а)
Progran hhh54;
var i,k,x:longint;
begin
k:=0;
read (x);
while x 0 do
begin
if (x mod 10 = 6) and (x mod 4 = 0); then k:=k+1;
read (x);
end;
write (k);
end.
б)
Progran hhh54;
var i,s,x:longint;
begin
s:=0;
read (x);
while x 0 do
begin
if (x mod 10 = 6) and (x mod 4 = 0); then s:=s+x;
read (x);
end;
write (s);
end.
- 06.09.2018 06:30
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.