Вопрос по информатике:
Решить задачу по информатике "В плацкартном вагоне 54 места, которые расположены в девяти купе. Места от 1 до 36 основные и они расположены по четыре в купе (1 - 4 в первом, ..., 33 - 36 в девятом), от 37 до 54 - боковые, разбиты по два, но расположение по купе обратное: места 37, 38 находятся в девятом купе, 39 и 40 в восьмом, ..., 53 и 54 в первом. По номеру места определите номер купе.
- 16.12.2015 13:50
- Информатика
- remove_red_eye 2445
- thumb_up 29
Ответы и объяснения 1
Запишем таблицу распределения мест по купе:
Купе Места
1 1-4,53,54
2 5-8,51,52
3 9-12,49,50
4 13-16,47,48
5 17-20,45,46
6 21-24,43,44
7 25-28,41,42
8 29-32,39,40
9 33-36,37,38
Установим связь номера места с номером купе. Предлагается следующий (конечно же, не единственный) вариант:
Здесь знаком ÷ обозначена операция целочисленного деления.
Теперь можно написать программу. Язык программирования в задании не указан, поэтому выбран язык свободно распространяемой для целей обучения системы программирования PascalABC.Net
var
n:integer;
begin
Write('Укажите номер места: '); Read(n);
Write('Место располагается в купе №');
if n<=36 then Write((n-1) div 4 + 1)
else Write((54-n) div 2 + 1)
end.
Тестовое решение:
Укажите номер места: 18
Место располагается в купе №5
- 17.12.2015 10:09
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.