Вопрос по информатике:
Напишите программу,которая для заданной последовательности натуральных чисел подсчитывает сумму входящих в неё трехзначных чисел,которые делятся на 7.Программа получает на вход кол-во чисел в прследовательности, а затем сами числа.Кол-во чисел не превышает 1000.Введенные числа не превышают 30 000.Программа должна вести одно число-сумму трехзначных чисел,находящихся в заданной последовательности натуральных чисел.
- 08.10.2016 04:26
- Информатика
- remove_red_eye 8060
- thumb_up 11
Ответы и объяснения 1
var n,x,i,s: longint;
begin
s:=0;
read (n);
for i:=1 to n do;
begin
read (x);
if (x > 99) and (x < 1000) and (x mod 7 = 0) then s:=s+x;
end;
write (s);
end.
- 09.10.2016 17:42
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.