Вопрос по информатике:
1) Напишите программу “Конвертер валют”. Вводим сумму в тенге, на
экран выводится сумма в долларах, рублях, евро
2) Поменять значения двух переменных местами:
Например:
int a = 5;
int b = 4;
Нужно, чтобы a стало равно 4, а b – 5.
Сделать задание двумя способами:
С использованием третьей переменной;
Без использования третьей переменной.
3) Объявить три переменные типа int и присвоить первой числовое
значение, вторая переменная равна первой переменной увеличенной на
3, а третья переменная равна сумме первых двух.
4) Создать небольшую программу “Список покупок”.
Создать 3 переменные для хранения цен товаров. С клавиатуры ввести
количество товаров и вывести на экран общую сумму покупок
- 01.09.2018 07:16
- Информатика
- remove_red_eye 19713
- thumb_up 12
Ответы и объяснения 1
1)
#include
using namespace std;
int main()
{
double s, s1, s2, s3;
cout << "1 тенге (KZT) = 0.19 RUB" << "\n";
cout << "1 тенге (KZT) = 0.002743 EUR" << "\n";
cout << "1 тенге (KZT) = 0.002995 USD" << "\n";
cout <> s, cout << "\n";
s1 = s*0.19;
s2 = s*0.002743;
s3 = s*0.002995;
cout << s << " тенге (KZT) = " << s1 << " RUB, " << s2 << " EUR, " << s3 << " USD" << "\n";
return 0;
}
Пример:
1 тенге (KZT) = 0.19 RUB
1 тенге (KZT) = 0.002743 EUR
1 тенге (KZT) = 0.002995 USD
Введите сумму в тенге:20000
20000 тенге (KZT) = 3800 RUB, 54.86 EUR, 59.9 USD
2 a)
#include
using namespace std;
int main()
{
int a = 5;
int b = 4;
int c;
c = a;
a = b;
b = c;
cout << "a = " << a << ", b = " << b << "\n";
return 0;
}
Результат:
a = 4, b = 5
2 b)
#include
using namespace std;
int main()
{
int a = 5;
int b = 4;
a = a+b;
b = a-b;
a = a-b;
cout << "a = " << a << ", b = " << b << "\n";
return 0;
}
Результат:
a = 4, b = 5
3)
#include
using namespace std;
int main()
{
int a, b, c;
a = 5;
b = a+3;
c = a+b;
cout << "a = " << a << ", b = " << b << ", c = " << c << "\n";
return 0;
}
Результат:
a = 5, b = 8, c = 13
4)
#include
using namespace std;
int main()
{
int p1=10;
int p2=15;
int p3=12;
int k1, k2, k3, s;
cout <> k1, cout << "\n";
cout <> k2, cout << "\n";
cout <> k3, cout << "\n";
s = p1*k1+p2*k2+p3*k3;
cout << "Общая стоимость покупок = " << s << "\n";
return 0;
}
k1 = 2
k2 = 5
k3 = 3
Общая стоимость покупок = 131
- 02.09.2018 01:53
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.