Вопрос по информатике:
Напишите программу в Pascal ABC, которая в последовательности целых чисел определяет количество чисел, кратных 5 или 9. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 5 или 9. Входные данные: 15 91 90 0 Выходные данные: 2
- 12.07.2018 16:09
- Информатика
- remove_red_eye 11209
- thumb_up 41
Ответы и объяснения 1
begin
k:=0;
readln(a);
while a0 do
begin
if (abs(a) mod 5=0)or(abs(a) mod 9=0)
then k:=k+1;
readln(a);
end;
writeln('k = ',k);
end.
Пример:
15
91
90
0
k = 2
- 13.07.2018 11:15
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.