Вопрос по информатике:
Дано целое двузначное положительное число n . Составьте программу, которая определяет, входят ли в него цифры 2 и 5
- 09.06.2018 15:45
- Информатика
- remove_red_eye 4546
- thumb_up 45
Ответы и объяснения 1
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if (a1=2)or(a2=2)
then writeln('В числе есть цифра 2');
if (a1=5)or(a2=5)
then writeln('В числе есть цифра 5');
if (a12)and(a22)and(a15)and(a25)
then writeln('В числе нет цифр 2 и 5');
end.
Пример:
a = 25
В числе есть цифра 2
В числе есть цифра 5
- 01.01.1970 00:00
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.