Вопрос по информатике:
Составить программу для решения следующей задачи: Приближенно можно считать, что скорость охлаждения горячего чая, налитого в стакан, пропорциональна разности между его температурой и температурой воздуха. За 1 минуту температура чая снижается на 3 % от разности этих температур. Вывести на экран температуру чая по истечении каждой минуты в течении 15 минут. Начальная температура воздуха - 20 градусов, начальная температура чая - 100.
Протокол:
Через 0 мин. - 100 градусов
Через 1 мин. - 97,6 градусов
Через 2 мин. - 95,3 градусов
Через 3 мин. - 93,1 градусов
…
- 04.06.2018 19:07
- Информатика
- remove_red_eye 8452
- thumb_up 48
Ответы и объяснения 1
var t,t1:real; i:integer;
begin
t:=100;
t1:=20;
for i:=0 to 15 do
begin
writeln('Через ',i,' мин. - ',t:4:1,' градусов');
t:=t-(t-t1)*0.03;
end;
end.
Результат:
Через 0 мин. - 100.0 градусов
Через 1 мин. - 97.6 градусов
Через 2 мин. - 95.3 градусов
...
Через 14 мин. - 72.2 градусов
Через 15 мин. - 70.7 градусов
- 05.06.2018 07:18
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.