Вопрос по информатике:
. Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3 и оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.через repeat until
- 20.04.2016 00:09
- Информатика
- remove_red_eye 3661
- thumb_up 26
Ответы и объяснения 1
A,N,i:integer;
Begin
Write('N = ');Read(N);
S:=0;
i:=1;
Repeat
Read(A);
if (A mod 3 = 0)and(A mod 10 = 4) then S:=S+A;
i:=i+1
Until i > N;
WriteLn('S = ',S);
End.
Пример работы программы:
N = 5
1 24 74 54 36
S = 78
- 21.04.2016 13:12
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.