Вопрос по информатике:
ПОМОГИТЕ, ПОЖАЛУЙСТА!
Напишите программу, которая переставляет элементы массива в обратном порядке без использования дополнительного массива. Программа должна считать массив, поменять порядок его элементов, затем вывести результат (просто вывести элементы массива в обратном порядке – недостаточно!)
Входные данные
Сначала задано число N — количество элементов в массиве (1N35). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные
Необходимо вывести массив, полученный после перестановки элементов.
Примеры
входные данные
6
4 5 3 4 2 3
выходные данные
3 2 4 3 5 4
- 03.04.2018 13:19
- Информатика
- remove_red_eye 18466
- thumb_up 39
Ответы и объяснения 2
// PascalABC.NET 3.2, сборка 1431 от 28.04.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrInteger(ReadlnInteger('n='));;
Reverse(a); a.Println
end.
Пример
n= 6
4 5 3 4 2 3
3 2 4 3 5 4
2. Школьный вариант в стиле ТурбоПаскаль 1983г.
const
nn=35;
var
i,n,t:integer;
a:array[1..nn] of integer;
begin
Readln(n);
for i:=1 to n do Read(a[i]);
for i:=1 to n div 2 do begin
t:=a[i]; a[i]:=a[n-i+1]; a[n-i+1]:=t
end;
for i :=1 to n do
Write(a[i],' ');
Writeln
end.
- 05.04.2018 07:00
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.
