Вопрос по информатике:
X^y+y^x!(!-факториал)
на паскале нужно написать программу для решения
- 19.09.2017 06:56
- Информатика
- remove_red_eye 10122
- thumb_up 34
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
function Pow(x,y:BigInteger):BigInteger;
begin
Result:=x;
for var i:=int64(2) to int64(y) do Result*=x
end;
begin
var x,y:integer;
Write('Введите натуральные х и у: '); Read(x,y);
if (x<=0) or (y<=0) then begin
Writeln('Неверный ввод'); Exit
end;
if x=1 then Writeln('Результат: ',y+1)
else begin
var x1:=Range(2,x).Aggregate(BigInteger(1),(a,b)->a*b);
Writeln('Результат ',Pow(x,y)+Pow(y,x1))
end
end.
Пример
Введите натуральные х и у: 5 8
Результат 2348542582773833227889480596789337027375682548908319870707290971532209025114608443463698998384768703032325601
- 20.09.2017 12:07
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.