Вопрос по информатике:
Срочно
Помогите пожалуйста
Написать программу на языке программирования Паскаль
1)зная температуру воздуха ,определить вид осадков (дождь или снег)
2)найдите сумму цифр заданного трехзначного числа
3)если первое число больше второго ,то определить квадрат меньшего числа ,а в противном случае - произведение чисел
- 01.02.2018 14:03
- Информатика
- remove_red_eye 3253
- thumb_up 11
Ответы и объяснения 1
t:integer;
Begin
Write('Введите температуру воздуха: ');ReadLn(t);
if t > 0 then Write('Дождь')
else Write('Снег')
End.
Var
A:integer;
Begin
Write('Введите трёхзначное число: ');ReadLn(A);
A:=Abs(A);
WriteLn(A div 100,'+',(A div 10) mod 10,'+',A mod 10,' = ',A div 100+(A div 10) mod 10+A mod 10);
End.
Var
A,B:integer;
Begin
Write('Введите два числа: ');ReadLn(A,B);
if A>B then Write('Квадрат меньшего: ',B*B)
else Write('Произведение чисел: ',A*B)
End.
- 02.02.2018 23:30
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.