Вопрос по информатике:
Ребят, помоги в паскале. напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0. В конце работы программы на экран выводится сумма и произведение введенных чисел.
- 05.01.2016 00:41
- Информатика
- remove_red_eye 17321
- thumb_up 50
Ответы и объяснения 1
Var a,s,p:integer;
begin
p:=1;
read(a);
if(a=0) then p:=0;
while(a0)do begin
s+=a;
p*=a;
read(a); end;
writeln(s, ' ', p);
end.
- 06.01.2016 14:51
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.