Вопрос по информатике:
Решать на Pascal ABC.net версия 3.2 сборка 1417. Написать программу, которая выполняет сравнение многоразрядных десятичных ЦЕЛЫХ чисел. То-есть вывести > если первое число больше второго; вывести < если второе число больше первого; вывести = если числа равны.
- 07.01.2015 00:14
- Информатика
- remove_red_eye 640
- thumb_up 41
Ответы и объяснения 2
Begin
Write('Введите два целых числа: ');ReadLn(a,b);
if a > b then Write(a,' > ',b)
else if a < b then Write(a,' < ',b)
else Write(a,' = ',b)
End.
- 08.01.2015 13:34
- thumb_up 23
begin
var a:=ReadlnString('1-е число:').ToBigInteger;
var b:=ReadlnString('2-е число:').ToBigInteger;
if a>b then Writeln('>')
else
if a=b then Writeln('=')
else Writeln('<')
end.
Пример
1-е число: 45685695606778795409839437392759354
2-е число: 8643603434233452532223423423525
>
Замечание: разрядность чисел - произвольная.
- 09.01.2015 13:55
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.