Вопрос по информатике:
1. Написать программу в Паскале, в результате выполнения которой на экране будут выведены 5 строк:
Меня зовут (фамилия, имя)
Я учусь в 7 «__» классе гимназии 524
Мое хобби ______________________
Периметр прямоугольника равен 30
Сегодня ярко светит солнце!
2. В трёх опросах ученик получил оценки. Составьте алгоритм и программу, которая определит среднее значение оценок, полученных учеником в трёх опросах. Оценки ввести с клавиатуры. Результат вывести на экран.
3. . Написать программу нахождения периметра прямоугольника по известным сторонам a и b (a и b – целые числа, вводимые с клавиатуры)
- 27.12.2017 10:02
- Информатика
- remove_red_eye 15988
- thumb_up 34
Ответы и объяснения 1
program anketa;
var a,b,d:string;
c:char;
begin
writeln('Введите ваши имя и фамилию в именительном падеже: ');
readln(a,b);
writeln('Введите букву класса: ');
readln(c);
writeln('Введите ваше хобби: ');
readln(d);
writeln('Меня зовут ',a,' ',b,';');
writeln('Я учусь в 7 "',c,'" классе гимназии 524;');
writeln('Моё хобби - ',d,';');
writeln('Периметр прямоугольника равен 30');
writeln('Сегодня ярко светит солнце!')
end.
2. Программа "Опросы":
program oprosy;
var a,b,c:integer;
d:real;
begin
writeln('Введите ваши оценки по пятибалльной шкале: ');
readln(a,b,c);
d:=(a+b+c)/3;
writeln('Ваша средняя оценка за тесты - ',d,'.');
end.
3. Программа "Периметр прямоугольника":
program perimetr;
var a,b,c:integer;
begin
writeln('Введите стороны прямоугольника: ');
readln(a,b);
c:=(a+b)*2;
writeln('Периметр прямоугольника = ',c,'.');
end.
- 28.12.2017 17:43
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.