Вопрос по информатике:
Напишите программу, которая вводит последовательность целых чисел, заканчивающуюся нулём, и определяет, сколько из этих чисел удовлетворяет условию: сумма значений цифр десятичной записи числа равно 10.
- 17.12.2017 00:18
- Информатика
- remove_red_eye 5355
- thumb_up 47
Ответы и объяснения 1
A,S,k:longint;
Begin
k:=0;
Read(A);
While A0 do
Begin
S:=0;
A:=Abs(A);
While A > 0 do
Begin
S:=S+A mod 10;
A:=A div 10;
End;
if S=10 then k:=k+1;
Read(A);
End;
WriteLn('Искомое количество: ',k);
End.
- 18.12.2017 03:22
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.