Вопрос по информатике:
Обувная фабрика собирается начать выпуск элитной модели ботинок. Дырочки для шнуровки будут расположены в два ряда, расстояние между рядами равно a, а расстояние между дырочками в ряду b. Количество дырочек в каждом ряду равно N.
Рис. 1 Шнуровка должна происходить элитным способом «наверх, по горизонтали в другой ряд, наверх, по горизонтали и т.д.» (см. рисунок). Кроме того, чтобы шнурки можно было завязать элитным бантиком, длина свободного конца шнурка должна быть l.
Какова должна быть длина шнурка для этих ботинок?
Входные данные
Вводятся четыре натуральных числа a, b, l и N.
Выходные данные
Ваша программа должна выводить одно число – искомую длину шнурка.
- 26.12.2015 22:05
- Информатика
- remove_red_eye 15480
- thumb_up 16
Ответы и объяснения 1
Из рисунка следует, что для N-1 пары отверстий, считая сверху, потребуется пройти двойное количество расстояний a и b, т.е. 2(N-1)(a+b). Еще одно расстояние a надо пройти между нижней парой отверстий и еще с каждой стороны остается свободный конец длины l. Тогда общая длина шнурка составит 2(N-1)(a+b)+a+2l
Ниже приведена программа на языке Паскаль (версия TP 7.01).
uses Crt;
var
a,b,l,N:integer;
begin
ClrScr;
Write('Vvedite a,b,l,N: ');
Read(a,b,l,N);
Writeln('Dlina=',2*(N-1)*(a+b)+a+2*l);
ReadKey
end.
Тестовое решение:
Vvedite a,b,l,N: 40 20 120 6
Dlina=880
- 27.12.2015 21:27
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.