Вопрос по информатике:
Написать программу в которой замена производится по такому правилу: если число делится на 2, то оно умножается на 4. Если нет - к нему прибавляется 1.
P.S. на Паскале.
Помогите, плиз! Я в информатике полный ноль. Спасибо!
- 27.05.2016 14:37
- Информатика
- remove_red_eye 1730
- thumb_up 35
Ответы и объяснения 1
//PascalABC.Net v3.1
var n:integer;
begin
readln(n);
if n mod 2 = 0 then n:=n*4 else n:=n+1;
writeln(n);
end.
- 28.05.2016 04:51
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.