Вопрос по информатике:
Помогите написать программу(Паскаль)
2. Для заданного набора коэффициентов a, b, c, d найдите наименьшее значение функции y = a x3 + b x2 + cx + d и значение аргумента, при котором оно получено. Значение х изменяется от 0 до 2 с шагом 0,2.
- 03.11.2015 02:27
- Информатика
- remove_red_eye 3817
- thumb_up 25
Ответы и объяснения 2
Begin
WriteLn('f(x) = ax^3 +bx^2 +cx +d');
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
Min:=0;
x:=0;
Repeat
if Min*(a*Min*Min+b*Min+c) > x*(a*x*x+b*x+c) then Min:=x;
x:=x+0.2;
Until x>2;
Write('d = ');ReadLn(d);
WriteLn('Min(f) = f(',Min,') = ',Min*(a*Min*Min+b*Min+c)+d)
End.
Пример работы программы:
f(x) = ax^3 +bx^2 +cx +d
a = 15
b = -17
c = -70
d = 0
Min(f) = f(1.6) = -94.08
- 04.11.2015 00:19
- thumb_up 20
begin
writeln('a, b, c, d:');
readln(a,b,c,d);
h:=0.2;
x:=0; y:=a*x*x*x+b*x*x+c*x+d;
writeln(x:2:1,' ',y:5:2);
minx:=0; miny:=y;
for i:=1 to round((2-0)/h)+1 do
begin
x:=x+h;
y:=a*x*x*x+b*x*x+c*x+d;
writeln(x:2:1,' ',y:5:2);
if y
writeln('min = y(',minx:2:1,') = ',miny:5:2);
end.
Пример:
a, b, c, d:
3 2 -1 4
0.0 4.00
0.2 3.90
0.4 4.11
0.6 4.77
0.8 6.02
1.0 8.00
1.2 10.86
1.4 14.75
1.6 19.81
1.8 26.18
2.0 34.00
2.2 43.42
min = y(0.2) = 3.90
- 05.11.2015 17:56
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.