Вопрос по информатике:
ДРУЗЬЯ,ПОМОГИТЕ ПОЖАЛУЙСТА♥♥♥ отдаю все баллы, что есть))
1) Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход кол-во чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 3. Программа должна вывести одно число- минимальное число, кратное 3.
2) Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, кол-во введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). Значение выводить с точностью до десятых.
Решить на Паскале♥
Буду очень благодарна!♥♥♥
- 21.08.2016 18:00
- Информатика
- remove_red_eye 13870
- thumb_up 14
Ответы и объяснения 1
Begin
Write('Количество чисел: ');ReadLn(n);
Repeat
Read(A);
n:=n-1;
Until A mod 3 = 0;
Min:=A;
For n:= n downto 1 do
Begin
Read(A);
if (A < Min)and(A mod 3 = 0) then Min:=A
End;
WriteLn(Min)
End.
Var
A,k:longint;
S:real;
Begin
k:=-1;
S:=0;
Repeat
Read(A);
if A mod 8 = 0 then
Begin
S:=S+A;
k:=k+1;
End;
Until A = 0;
if k = 0 then WriteLn('NO')
else WriteLn('Sr = ',S/k:0:1)
End.
- 22.08.2016 00:06
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.