Вопрос по информатике:
Определите средний балл всех решить на С#Определите средний балл всех учащихся по каждому предмету.
Формат входных данных Заданы сначала количество учащихся n, затем n строк, каждая из которых содержит фамилию, имя и три числа (оценки по трем предметам: математике, физике, информатике). Данные в строке разделены одним пробелом. Оценки принимают значение от 1 до 5.
Формат выходных данных Выведите три действительных числа: средний балл всех учащихся по математике, по физике, по информатике.Пример
Ввод Вывод
4 4.75 3.75 4.5
Ivanov Vasiliy 5 3 4
Petrov Sergey 4 3 5
Konstantinov Nikolay 5 5 5
Kuznetsov Ivan 5 4 4
- 01.03.2016 03:23
- Информатика
- remove_red_eye 2132
- thumb_up 44
Ответы и объяснения 1
Int n;
public struct shkolyari{
int a1,a2,a3;
String name;
}obj[n];
Console.Readln(n);
for(int i =0 ; i
Console.Readln(obj[i].name + a1+a2+a3);
}
for(int i =0 ; i
int sum1 = sum1+obj[i].a1;
int sum2 = sum2+obj[i].a2;
int sum3 = sum3+obj[i].a3;
}
Console.WriteLine(\ sum1 + sum2 + sum3 )
- 02.03.2016 06:27
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.