Вопрос по информатике:
Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область
Входные данные
Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x -координата, затем – y -координата).
Выходные данные
Программа должна вывести слово 'YES', если точка попала в заштрихованную область, и слово 'NO', если не попала.
входные данные
0. 1.
выходные данные
NO
входные данные
0. -1.
выходные данные
YES
На языке программирования, удобном для вас
- 10.04.2018 06:37
- Информатика
- remove_red_eye 2969
- thumb_up 25
Ответы и объяснения 1
var
x, y: real;
begin
read(x, y);
if (y > sqr(x)-2) and ((y < x) or (y < -x)) then
writeln('YES')
else
writeln('NO')
end.
- 11.04.2018 14:14
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.