Вопрос по информатике:
II. Написать программу, которая подсчитывает: 1) периметр квадрата, площадь которого равна а; 2) площадь равностороннего треугольника, периметр которого равен р;
- 06.11.2017 20:16
- Информатика
- remove_red_eye 5195
- thumb_up 16
Ответы и объяснения 1
i: integer;
label 1, 2, 3, 4;
begin
1:
Writeln('1)Периметр квадрата');
Writeln('2)Площадь равностороннего треугольника');
Write('Ваш выбор >>> ');
Read(n);
Writeln('===========================');
if n = 1 then
begin
2:
Write('Введите площадь кварата >>> ');
Read(s);
if s < 0 then
begin
Writeln('Некорректный ввод');
Writeln('===========================');
goto 2;
end;
a := Sqrt(s) * 4;
Writeln('===========================');
Writeln('Периметр квадрата >>> ', a);
goto 4;
end
else
if n = 2 then
begin
3:
Write('Введите периметр равностороннего треугольника >>> ');
Read(a);
if a < 0 then
begin
Writeln('Некорректный ввод');
Writeln('===========================');
goto 3;
end;
s := (sqrt(3) / 4) * Sqr(a/3);
Writeln('===========================');
Writeln('Площадь равностороннего треугольника >>> ', s);
goto 4;
end
else
begin
Writeln('Некорректный ввод');
Writeln('===========================');
goto 1;
end;
4:
Writeln('===========================');
Writeln('1)Заного');
Writeln('2)Выйти');
Write('Ваш выбор >>> ');
Read(n);
Writeln('===========================');
if n = 1 then
goto 1 ;
else
exit;
end.
- 07.11.2017 13:59
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.