Вопрос по информатике:
Написать программу, которая после введенного с клавиатуры числа ( в диапозоне от 1 до 99) обозначающего денежную единицу, дописывает слово рубль в правильной форме. Например 12 рублей, 21 рубль.
- 13.04.2015 13:12
- Информатика
- remove_red_eye 3852
- thumb_up 31
Ответы и объяснения 1
Вот на Pascal (Console Aplication) :
var
a:Integer;
begin
Writeln('Vvedite nominal valuti');
Readln(a);
case (a mod 10) of
1:
if (a=11) then
Writeln('Y Vas est ',a,' rublei')
else
begin
Writeln('Y Vas est ',a,' rubl');
end;
2,3,4:
if (a=12) or (a=13) or (a=14) then
Writeln('Y Vas est ',a,' rublei')
else
begin
Writeln('Y Vas est ',a,' rublya');
end;
0,5,6,7,8,9:
if (a=15) or (a=16) or (1=17) or (a=18) or (a=19) then
Writeln('Y Vas est ',a,' rublei')
else
begin
Writeln('Y Vas est ',a,' rublei');
end;
end;
Readln;
end.
- 14.04.2015 11:22
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.