Вопрос по информатике:
Составить алгоритм сложения двух целых чисел B и N, вводимых с клавиатуры. Результат сложения записать в виде переменной P. По данному алгоритму написать программу в Паскале.
Алгоритм
1)алг сложение
цел B,N,P
нач
ввод B
ввод N
P:=B+N
вывод P
кон
2)алг сложение
цел B,N,P
нач
ввод B
ввод N
P=B+N
вывод P
кон
3)алг сложение
цел B,N,P
нач
ввод B
ввод P
N:=B+P
вывод P
кон
Программа в Паскале
1)program summa;
var
B,N,P:integer;
begin
readln(B);
readln(N);
P:=B+N;
writeln(P);
end.
2)program summa;
var
B,N,P:integer;
begin
readln(B);
readln(N);
P:=B+N;
writeln(P);
3)program summa;
var
B,N,P:integer;
begin
readln(B);
readln(N);
P:=B+N;
writeln(B);
end.
- 14.05.2018 01:38
- Информатика
- remove_red_eye 19732
- thumb_up 42
Ответы и объяснения 1
Алгоритм
1)алг сложение
цел B,N,P
нач
ввод B
ввод N
P:=B+N
вывод P
кон
Программа в Паскале
1)program summa;
var
B,N,P:integer;
begin
readln(B);
readln(N);
P:=B+N;
writeln(P);
end.
- 15.05.2018 23:09
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.