Вопрос по информатике:
Задание в паскале нужно написать программу:
Дан двумерный массив случайных чисел от -05 до 14 из 5 строк и 5 столбцов.Вывести на экран первоначальные значения элементов массива в виде матрицы. Поменять местами первый и второй столбец.Вывести на экран новые значения элементов массива в виде матрицы
Кто знает,помогите, с меня презент)
- 24.09.2017 17:26
- Информатика
- remove_red_eye 8814
- thumb_up 27
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив ***');
var a:=MatrRandom(5,5,-5,14);
a.Println(4); Writeln(4*a.ColCount*'-');
a.SwapCols(0,1);
Writeln('*** Результирующий массив ***');
a.Println(4);
end.
Пример
*** Исходный массив ***
12 10 7 -2 5
14 0 7 1 14
0 -1 7 5 7
-5 -5 -4 -4 9
7 8 -5 12 12
--------------------
*** Результирующий массив ***
10 12 7 -2 5
0 14 7 1 14
-1 0 7 5 7
-5 -5 -4 -4 9
8 7 -5 12 12
- 25.09.2017 11:34
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.