Вопрос по информатике:
Сколько различных значений числа d можно ввести, чтобы после выполнения программы было напечатано 196?
var n, s, d: integer;
begin
readln(d);
n := 7;
s := 35;
while s <= 2570 do begin
s := s + d;
n := n + 9
end;
write(n)
end.
- 03.09.2017 07:35
- Информатика
- remove_red_eye 11287
- thumb_up 48
Ответы и объяснения 1
n := 7+9*((2570-35) div d + 1)
196 = 7+9*((2570-35) div d + 1)
(196-7)/9-1 = (2570-35) div d
20 = 2535 div d
4 = 507 div d
507/4 =126.75, значит можно взять меньше
подбором 126 125 124 123 122 121 => 6 чисел
или программой
//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
function f(d: integer): integer;
var
n, s: integer;
begin
n := 7;
s := 35;
while s <= 2570 do
begin
s := s + d;
n := n + 9
end;
f := n;
end;
begin
for var i := 1 to 100000000 do
begin
if f(i) = 196 then writeln(i);
if f(i) 7 + 9 * ((2570 - 35) div i + 1) then writeln('not ', i);
end;
end.
- 04.09.2017 02:34
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.